Project

General

Profile

Bug #13258

Missing data from AmbientWeather weather stations

Added by Philippe May 11 days ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
21/11/2021
Due date:
% Done:

0%

Close

Description

For the last few days, the Gisaf scheduler fails to get data from AmbientWeather web site.

History

#1 Updated by Philippe May 11 days ago

There's the usual work around when instant data from the weather stations fail: recollect most missing data with manual imports from web sites historical records, eg:

(gisaf) gisaf@gisaf2:~/gisaf$ ~/../avgs_device_interfaces/fix_missing_ws_data.py --wsid 4 --start-date 20211117 --end-date 20211122

#2 Updated by Philippe May 11 days ago

  • Status changed from New to Resolved

I tried to run manually the "ambient_weather" job of the Gisaf scheduler:

./scheduler.py --job-name ambient_weather --debug

The debug messages do not show that the scheduler subscribe to the channel (part of the socketio protocol used by AmbientWeather).

Same command on my laptop, after upgrading to the latest versions of python dependencies: success.

OK, try the same again on the server: success.

So, it seems all good now but i don't know the root cause for sure. Either there was a glitch on AmbientWeather (ie. blocking the server IP, that was unblocked somehow), or there was some upgrade that required the newest versions of the python libraries?

Closing this for now as it's back to normal.

Also available in: Atom PDF